US - Service outage for iAuditor Web Platform and Syncing
Incident Report for SafetyCulture Global
Resolved
This issue has been resolved. Our services are back to normal.
Posted over 1 year ago. Mar 21, 2018 - 07:19 AEDT
Monitoring
We are currently experiencing an issue with the iAuditor Web Platform and mobile syncing, due to an outage of AWS Services in US-EAST-1.

Our engineering team continues to monitor the situation and will provide further updates following AWS resolution.
Posted over 1 year ago. Mar 21, 2018 - 03:00 AEDT