Instant chat outage
Incident Report for SafetyCulture Global
Resolved
Chat outage may still be intermittent as the team are working on fixing this up.
If you are being affected by this, you can still reach out to our support team via the contact page at https://safetyculture.com/contact-us/
Posted over 1 year ago. Apr 18, 2018 - 09:51 AEST
Investigating
We are aware of ongoing outage with our instant chat feature
Posted over 1 year ago. Apr 18, 2018 - 03:07 AEST