Bulk export via PDF not working on AU and EU Data Centers from the Inspections page.
Incident Report for SafetyCulture
Resolved
This incident has been resolved.
Posted May 13, 2022 - 15:36 UTC
Investigating
We are currently investigating an issue where iAuditor on web is unable to export PDFs in bulk for EU and AU Data Centers.

Currently, the best workaround is to use the Analytic's bulk export function or export the reports individually.
Posted May 13, 2022 - 14:43 UTC
This incident affected: Dublin (EU) (iAuditor Web Platform) and Sydney (AU) (iAuditor Web Platform).