Web Application is experiencing loading failures
Incident Report for SafetyCulture Status
Resolved
A fix has been applied and all Web application services are now back up and running.
Posted Sep 17, 2020 - 11:39 AEST
Identified
The issue has been identified and a fix is being implemented
Posted Sep 17, 2020 - 11:01 AEST
Investigating
We are currently investigating this issue.
Posted Sep 17, 2020 - 10:37 AEST
This incident affected: Virginia (US) (iAuditor Web Platform), Dublin (EU) (iAuditor Web Platform), and Sydney (AU) (iAuditor Web Platform).