Web App Outage - 'Unable to log in'
Incident Report for SafetyCulture Status
Resolved
This incident has been resolved.
Posted Oct 20, 2021 - 11:38 UTC
Investigating
We are experiencing issues logging into the web app and our engineers are looking into this.
Posted Oct 20, 2021 - 10:36 UTC
This incident affected: Sydney (AU) (iAuditor Web Platform), Virginia (US) (iAuditor Web Platform), and Dublin (EU) (iAuditor Web Platform).