Delay in processing Inspection History data
Incident Report for SafetyCulture
Resolved
This incident has been resolved.
Posted May 02, 2022 - 22:45 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 02, 2022 - 22:30 UTC
Investigating
We are currently experiencing delays in processing Inspection History data.

At the moment, the Team is investigating the issue and we apologize for any inconvenience caused.
Posted May 02, 2022 - 21:51 UTC
This incident affected: Virginia (US) (iAuditor Mobile, iAuditor Web Platform).