Experiencing delays in the Support Live Chat

Incident Report for SafetyCulture

Resolved

This incident is now resolved.
Posted May 10, 2024 - 19:31 UTC

Update

We are continuing to work on a fix for this issue.
Posted May 10, 2024 - 19:09 UTC

Identified

The issue has been identified and a fix is being implemented.

You may still reach out to us at:

Email:
- support@safetyculture.com

Phone:
- Kansas City: +1 816 787 1343
- Manchester: +44 161 768 1124
- Sydney: +61 1300 984 245
- Townsville: +61 1300 984 245
Posted May 10, 2024 - 17:01 UTC

Investigating

We are currently investigating the issue. For urgent concerns, the Support team can still be contacted via email and phone calls.

You may reach out to us at:

Email:
- support@safetyculture.com

Phone:
-Kansas City: +1 816 787 1343
- Manchester: +44 161 768 1124
- Sydney: +61 1300 984 245
- Townsville: +61 1300 984 245
Posted May 10, 2024 - 15:40 UTC
This incident affected: SafetyCulture (Mobile App, Web Platform).