Customers in the EU data centre unable to create templates.
Incident Report for SafetyCulture Status
Resolved
This incident has been resolved. Template creation should now be functioning normally.

Thank you for your patience.
Posted Sep 01, 2020 - 18:52 AEST
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 01, 2020 - 17:37 AEST
This incident affected: Dublin (EU) (iAuditor Web Platform).