Customers in US Data centre unable to access platform.
Incident Report for SafetyCulture Global
Resolved
This incident has been resolved.
Posted Jun 24, 2020 - 22:02 AEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 24, 2020 - 21:44 AEST
Update
We are continuing to investigate this issue.
Posted Jun 24, 2020 - 21:11 AEST
Investigating
We are aware of on ongoing incident whereby customers using the US data centre are unable to access iAuditor via web or mobile device. Thank you for your patience whilst we get this resolved.
Posted Jun 24, 2020 - 20:54 AEST
This incident affected: Virginia (US) (iAuditor Web Platform, iAuditor iOS, iAuditor Android), Dublin (EU) (iAuditor Web Platform, iAuditor iOS, iAuditor Android), and Sydney (AU) (iAuditor Web Platform, iAuditor iOS, iAuditor Android).