Issues accessing iAuditor via Internet Explorer 11
Incident Report for SafetyCulture
Resolved
Everything is back to normal! Let us know if you encounter any problems.
Posted Aug 02, 2018 - 12:30 UTC
Monitoring
Our Engineering team have identified and resolved the issue impacting I.E 11.

Customers will now be able to access iAuditor via I.E 11 as normal. While services have been restored we will continue to monitor this issue closely
Posted Aug 02, 2018 - 11:27 UTC
Investigating
We are currently aware of an issue impacting access to iAuditor via Internet Explorer 11; customers may experience browser lockups and will be unable to access their Audits/Templates.

We are continuing to investigate the issue and will provide more information as it becomes available.
Posted Aug 02, 2018 - 09:53 UTC
This incident affected: SafetyCulture (Web Platform).