Website and Support Knowledgebase unavailable
Incident Report for SafetyCulture Global
Resolved
This incident has been resolved.
Posted 8 months ago. Feb 07, 2019 - 22:53 AEDT
Monitoring
We have rolled out fixes to www.safetyculture.com and it is operating as expected. We are continuing to monitor to ensure no other issues remain.
Posted 8 months ago. Feb 07, 2019 - 22:52 AEDT
Identified
We are currently experiencing difficulties with www.safetyculture.com and the knowledge base support.safetyculture.com. iAuditor is unaffected, and you may continue to log in using https://app.safetyculture.io/
Posted 8 months ago. Feb 07, 2019 - 20:46 AEDT