Unable to login to the SafetyCulture (iAuditor) app
Incident Report for SafetyCulture
Resolved
This incident has been resolved.

We apologize for any inconvenience this may have caused and thank you for your understanding.
Posted Jan 17, 2023 - 00:40 UTC
Monitoring
A fix has been implemented, and we're currently monitoring the results.
Posted Jan 17, 2023 - 00:26 UTC
Update
We're aware of an issue where customers are unable to login to the SafetyCulture (iAuditor) app on Web and Mobile. Our team are looking into this issue and apologise for any inconvenience caused.
Posted Jan 17, 2023 - 00:21 UTC
Investigating
We're aware of an issue where customers are unable to login to the SafetyCulture (iAuditor) web app. Our team are looking into this issue and apologise for any inconvenience caused.
Posted Jan 17, 2023 - 00:11 UTC
This incident affected: SafetyCulture (formerly iAuditor) (Mobile App, Web Platform).