Users unable to log in to the SafetyCulture app

Incident Report for SafetyCulture

Resolved

This incident has been resolved.
Posted Jun 24, 2025 - 08:20 UTC

Update

We're aware of an issue where customers are unable to log in to the SafetyCulture app. This may also affect some public API.

Our team is currently investigating this issue.
Posted Jun 24, 2025 - 06:34 UTC

Investigating

We're aware of an issue where customers are unable to log in to the SafetyCulture app. Our team is currently investigating this issue.
Posted Jun 24, 2025 - 06:05 UTC
This incident affected: SafetyCulture (Public API, Mobile App, Web Platform).