Unable to load data on Legacy Analytics

Incident Report for SafetyCulture

Resolved

This incident has been resolved.
Posted Sep 05, 2024 - 04:37 UTC

Investigating

We are aware that some users cannot load data on Legacy Analytics. Our team is still currently investigating this issue.
Posted Sep 04, 2024 - 13:30 UTC
This incident affected: SafetyCulture (Analytics).