Pending Invites tab showing "Something went wrong" error message
Incident Report for SafetyCulture Status
Resolved
This incident has been resolved.
Posted Dec 15, 2021 - 11:50 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 15, 2021 - 11:47 UTC
Identified
The Pending Invites tab is showing an error message when accessing the Users page. Issue identified, working on the fix.
Posted Dec 15, 2021 - 11:00 UTC
This incident affected: Virginia (US) (iAuditor Web Platform), Dublin (EU) (iAuditor Web Platform), and Sydney (AU) (iAuditor Web Platform).