Inspections temporarily unavailable
Incident Report for SafetyCulture
Resolved
The issue has now been resolved. Thank you for your patience and understanding.

Please reach out to our Support Team if need any additional assistance.
Posted May 09, 2023 - 19:35 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 09, 2023 - 19:14 UTC
Update
We are continuing to investigate this issue.
Posted May 09, 2023 - 18:55 UTC
Update
We are continuing to investigate this issue.
Posted May 09, 2023 - 18:00 UTC
Investigating
We have received reports of issues with Inspections & Templates.

Our engineering teams are currently investigating.

We apologize for any inconvenience.

Please reach out to the Customer Support team if you require any further assistance.
Posted May 09, 2023 - 18:00 UTC
This incident affected: SafetyCulture (Inspections).