We are aware of an issue with multiple features not loading

Incident Report for SafetyCulture

Resolved

This incident is now resolved.
Posted Sep 22, 2023 - 03:47 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 22, 2023 - 00:54 UTC

Identified

We have identified the issue with features not loading. A fix has been applied and customers should experience more stability while we monitor the situation.
Posted Sep 22, 2023 - 00:37 UTC

Update

We are continuing to investigate this issue and have discovered multiple features in the SafetyCulture platform may experience delays or not load at all. Our team is currently investigating this.
Posted Sep 22, 2023 - 00:26 UTC

Investigating

We are currently aware of an issue where there noticeable issues and delays related to Sensors, Actions and Media. Our engineering teams are investigating.
Posted Sep 22, 2023 - 00:00 UTC
This incident affected: SafetyCulture (Inspections, Sensors, Actions).