Weather sensors may be experiencing delays in receiving the latest weather readings

Incident Report for SafetyCulture

Resolved

This incident has been resolved.
Posted Nov 10, 2023 - 10:29 UTC

Monitoring

We have observed some sensors starting to come back online, and we are monitoring the progress.
Posted Nov 10, 2023 - 10:21 UTC

Investigating

Customers with weather sensors may be experiencing delays in receiving the latest weather readings.

We are investigating the cause.
Posted Nov 10, 2023 - 08:41 UTC
This incident affected: SafetyCulture (Sensors).