Mobile app not Syncing
Incident Report for SafetyCulture Status
Resolved
This incident has been resolved.
Posted Jul 21, 2021 - 12:10 AEST
Investigating
We're currently investigating issues being experienced with syncing from mobile that is providing a "Sync Failed" error message.
Posted Jul 21, 2021 - 03:20 AEST
This incident affected: Dublin (EU) (iAuditor Mobile).