Some users with older templates are unable to save template edits

Incident Report for SafetyCulture

Resolved

This incident has been resolved.
Posted Jul 15, 2026 - 04:08 UTC

Monitoring

A fix has been deployed, and Templates should now be working normally for all SafetyCulture customers. We will continue to monitor closely.
Posted Jul 14, 2026 - 13:55 UTC

Investigating

We are currently investigating this issue.
Posted Jul 14, 2026 - 09:51 UTC
This incident affected: SafetyCulture (Inspections).