Latency across SafetyCulture platform

Incident Report for SafetyCulture

Resolved

This incident has been resolved.
Posted Oct 25, 2023 - 14:22 UTC

Monitoring

Our team have deployed a fix to address latency across our platform.

We will continue to monitor this closely.
Posted Oct 25, 2023 - 14:03 UTC

Identified

Our team has identified the underlying issue and is working towards a fix.

We appreciate your patience and apologize for any inconvenience caused.
Posted Oct 25, 2023 - 13:45 UTC

Update

We are continuing to investigate this issue.
Posted Oct 25, 2023 - 11:01 UTC

Update

Our engineering teams are currently investigating.
Posted Oct 25, 2023 - 10:10 UTC

Update

Our engineers are continuing to investigate this issue.

We apologize for any inconvenience caused.
Posted Oct 25, 2023 - 08:53 UTC

Investigating

We have received reports of issues with latency across our platform.

Our engineering teams are currently investigating.
Posted Oct 25, 2023 - 08:13 UTC