Degraded performance in 'Actions' feature.
Incident Report for SafetyCulture Status
Resolved
We have now discovered and addressed the performance issues. Actions services are now operating as expected.

We apologise for any inconvenience caused.
Posted Oct 07, 2020 - 10:55 AEDT
Investigating
Our Actions Team are aware of eventual degraded performance in Actions list and timeline, where users might face significant delays while loading those pages.

We thank you for your patience and hope to have this resolved quickly.
Posted Oct 07, 2020 - 01:03 AEDT
This incident affected: Virginia (US) (iAuditor Web Platform).