Users are unable to edit investigation details

Incident Report for SafetyCulture

Resolved

This incident has been resolved.
Posted Feb 11, 2026 - 12:02 UTC

Investigating

We are aware of a problem with editing the details of an investigation.

We are currently looking into this issue.
Posted Feb 11, 2026 - 10:53 UTC
This incident affected: SafetyCulture (Issues).