SafetyCulture experiencing platform intermittent outages

Incident Report for SafetyCulture

Resolved

This incident has been resolved.
Posted Apr 26, 2025 - 02:46 UTC

Monitoring

We are monitoring a fix that has been applied, and some services have started responding. Another update will be supplied within the hour.
Posted Apr 26, 2025 - 01:59 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 26, 2025 - 01:13 UTC

Investigating

We are currently experiencing issues with several services. This is affecting all regions. We have diagnosed the root cause and are looking to implement a fix. An update will be provided within the next hour.
Posted Apr 26, 2025 - 01:10 UTC
This incident affected: SafetyCulture (Inspections, Issues, Sensors, Assets, Analytics, Public Library, Heads Up, Public API, Mobile App, Web Platform, Training, Actions, Integrations, Website).