Website, safetyculture.com showing internal error
Incident Report for SafetyCulture
Resolved
The incident has been resolved. Our website https://www.safetyculture.com/ is now up and running.
Posted Dec 14, 2023 - 05:12 UTC
Identified
Our website https://www.safetyculture.com/ is now up and running, however, there are still issues with some of its links.

The team has identified the issue and are working on fixes.
Posted Dec 14, 2023 - 03:15 UTC
Investigating
We are aware that our website https://www.safetyculture.com/ is showing an internal error.

Our team is currently investigating.
Posted Dec 14, 2023 - 02:47 UTC
This incident affected: SafetyCulture (formerly iAuditor) (Website).