Some inspections are unable to be marked as complete
Incident Report for SafetyCulture
Resolved
This incident has been resolved.
Posted Feb 19, 2024 - 05:38 UTC
Identified
We have identified the issue that is causing inspections unable to be marked as complete on the web app. Our engineering teams are working on a resolution.
Posted Feb 19, 2024 - 04:29 UTC
Investigating
We have received reports of issues with inspections unable to be marked as complete on the web app.

A current work around is to use a mobile device to complete the inspections.

Our engineering teams are currently investigating and working on a resolution
Posted Feb 19, 2024 - 04:23 UTC
This incident affected: SafetyCulture (Inspections).