Support Chat and Email experiencing latency
Incident Report for SafetyCulture Status
Resolved
Performance of our Support system is back to normal, however we have a long backlog of Support enquiries that the team is working hard on working through. We thank you for your patience on this.
Posted Dec 08, 2021 - 03:14 UTC
Monitoring
A fix has been implemented, however we are still monitoring performance of our Support system. Apologies as there still could be some delays due to the backlog.
Posted Dec 08, 2021 - 00:31 UTC
Update
We have identified that our third-party vendors are having issues with their system which is causing the issue with sending chats and emails to our support team.
Posted Dec 07, 2021 - 18:33 UTC
Identified
The Support team is currently experiencing issues with latency from chat and email. Working on getting this resolved.
Posted Dec 07, 2021 - 16:13 UTC