Password reset page is temporarily unavailable.

Incident Report for SafetyCulture

Resolved

This incident has been resolved.
Posted Aug 06, 2026 - 03:58 UTC

Identified

We are currently experiencing a technical problem with our password reset page.

The issue has been identified, and we are working on a fix.
Posted Aug 06, 2026 - 03:49 UTC
This incident affected: SafetyCulture (Web Platform).