Public URL links are leading recipient to the login page
Incident Report for SafetyCulture
Resolved
Public URL links can now be opened without being redirected to the login page.

This incident has been resolved.
Posted Aug 22, 2023 - 11:08 UTC
Investigating
We are currently aware of an issue where public links redirect recipients to the SafetyCulture login page.
Our engineering team is investigating.
Posted Aug 22, 2023 - 10:25 UTC
This incident affected: SafetyCulture (Inspections, Heads Up, Web Platform, Actions).