Some weather sensors may experience delays
Incident Report for SafetyCulture
Resolved
This incident has been resolved.
Posted Jul 21, 2023 - 05:23 UTC
Update
We are continuing to investigate this issue.
Posted Jul 20, 2023 - 21:09 UTC
Investigating
We are currently investigating an issue where weather sensor readings are experiencing delays.

We apologize for any inconvenience caused.
Posted Jul 20, 2023 - 15:24 UTC
This incident affected: SafetyCulture (formerly iAuditor) (Sensors).