We're aware of an issue with the iAuditor Mobile App on Android.
Incident Report for SafetyCulture
Resolved
iAuditor is now available to download and update on the PlayStore.
Posted Apr 21, 2022 - 13:45 UTC
Update
We are continuing to investigate this issue and are working with Google to have this resolved as soon as possible.

In the meantime, you can download the app through the steps listed here:

https://help.safetyculture.com/en_us/1109032984-ryGQTPtNP
Posted Apr 20, 2022 - 04:22 UTC
Update
We are continuing to investigate this issue.
Posted Apr 19, 2022 - 11:10 UTC
Investigating
We are aware of an issue where the mobile application on Android is temporarily unavailable for download from the Play Store.

In the meantime, you can download the app through the steps listed here:

https://help.safetyculture.com/en_us/1109032984-ryGQTPtNP
Posted Apr 19, 2022 - 10:19 UTC
This incident affected: Sydney (AU) (iAuditor Mobile), Dublin (EU) (iAuditor Mobile), and Virginia (US) (iAuditor Mobile).