Failed to send notifications
Incident Report for SafetyCulture
Resolved
This incident has been resolved.
Posted Sep 12, 2024 - 22:40 UTC
Investigating
We are aware that some product notifications were not sent from the platform around 2:15 PM Universal Time Coordinated (UTC). We are aware of the issue and are currently working on it.
Posted Sep 12, 2024 - 22:26 UTC