Some notifications deliveries have been delayed

Incident Report for SafetyCulture

Resolved

This incident has been resolved.
Posted Jan 20, 2026 - 00:51 UTC

Identified

We have identified the cause of the notification delivery delay. We are working through it.
Posted Jan 19, 2026 - 22:21 UTC
This incident affected: SafetyCulture (Inspections, Issues, Heads Up, Actions).