Some users unable to log into the SafetyCulture app

Incident Report for SafetyCulture

Resolved

This incident has been resolved.
Posted Jun 25, 2025 - 02:34 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 25, 2025 - 02:29 UTC

Identified

Our team has identified the issue and is implementing a fix.

We appreciate your patience.
Posted Jun 25, 2025 - 02:24 UTC

Investigating

We're aware of an issue where some users are unable to log into the SafetyCulture app.

Our team is currently investigating this issue.
Posted Jun 25, 2025 - 02:08 UTC
This incident affected: SafetyCulture (Web Platform).