Support channel disruption

Incident Report for SafetyCulture

Resolved

This incident has been resolved.
Posted Jan 09, 2026 - 21:22 UTC

Monitoring

A fix has been implemented, and we are monitoring the results.
Posted Jan 09, 2026 - 20:52 UTC

Investigating

We are experiencing an outage affecting customer support channels.

Users may be unable to start conversations or may experience delayed or incomplete responses.
Posted Jan 09, 2026 - 20:40 UTC
This incident affected: SafetyCulture (Mobile App, Web Platform).