Training may not be loading for some users
Incident Report for SafetyCulture
Resolved
This incident has been resolved.
Posted Jan 30, 2025 - 05:20 UTC
Investigating
We're aware of an issue where Training may not be loading for some users and are currently investigating.
Posted Jan 29, 2025 - 23:08 UTC
This incident affected: SafetyCulture (Training).