Unable to load/create actions and issues
Incident Report for SafetyCulture
Resolved
This incident has been resolved.
Posted Feb 29, 2024 - 09:09 UTC
Investigating
We have received reports of certain users not being able to load/create actions and issues. Our engineering teams are currently investigating.
Posted Feb 29, 2024 - 08:11 UTC
This incident affected: SafetyCulture (Issues, Actions).