Service outage for some sensors

Incident Report for SafetyCulture

Resolved

This incident has been resolved.
Posted Jul 24, 2026 - 12:53 UTC

Monitoring

A fix has been deployed and Sensors should now be working normally for all SafetyCulture customers. We will continue to monitor closely.
Posted Jul 24, 2026 - 10:37 UTC

Investigating

We are currently aware of an issue impacting Sensors. Our engineering teams are investigating, and we will provide updates as soon as they are available.
Posted Jul 24, 2026 - 08:58 UTC
This incident affected: SafetyCulture (Sensors).