Course Library is not working for some users

Incident Report for SafetyCulture

Resolved

This incident has been resolved.
Posted Feb 12, 2025 - 05:36 UTC

Investigating

We're aware of an issue with the course library not loading for some users. Our team is currently investigating.
Posted Feb 12, 2025 - 02:53 UTC
This incident affected: SafetyCulture (Training).