Completed scheduled inspections still appearing as "In Progress"

Incident Report for SafetyCulture

Resolved

This incident has been resolved. For completed scheduled inspections that still appear as "in progress", marking the inspection as incomplete then complete again should update it with the correct status.
Posted Feb 08, 2023 - 22:24 UTC

Investigating

We're currently investigating an issue wherein completed scheduled inspections are still appearing as "In Progress".
Posted Feb 08, 2023 - 20:44 UTC
This incident affected: SafetyCulture (Mobile App, Web Platform).