Delay in loading analytics page.
Incident Report for SafetyCulture
Resolved
This incident has been resolved.
Posted Oct 03, 2022 - 21:57 UTC
Update
We are continuing to monitor for any further issues.
Posted Oct 03, 2022 - 20:20 UTC
Update
We are continuing to monitor for any further issues.
Posted Oct 03, 2022 - 17:48 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 03, 2022 - 17:02 UTC
Update
We are continuing to investigate this issue.
Posted Oct 03, 2022 - 16:47 UTC
Investigating
We are currently experiencing delays in our analytics page loading. Apologies for any inconvenience. Our team is currently investigating the issue.
Posted Oct 03, 2022 - 15:47 UTC
This incident affected: Sydney (AU) (SafetyCulture Web Platform), Virginia (US) (SafetyCulture Web Platform), and Dublin (EU) (SafetyCulture Web Platform).