Remove a user from a group API incorrectly removes user from organization

Incident Report for SafetyCulture

Resolved

Our engineering team has identified the cause of the issue.

If your organization has been impacted, a member of the SafetyCulture team will be in touch directly to discuss next steps.
Posted Aug 04, 2025 - 08:52 UTC

Investigating

We are currently investigating an issue where using the "remove user from group" API is incorrectly removing the user from the platform entirely. Our engineering team is actively working on a solution.
Posted Aug 04, 2025 - 05:53 UTC
This incident affected: SafetyCulture (Integrations).