New scheduling events are not recorded in organization activity log

Incident Report for SafetyCulture

Resolved

This incident has been resolved.
Posted Apr 01, 2026 - 08:39 UTC

Investigating

We are aware of an issue wherein the new scheduling events are missing in the organization's activity log.

We are currently investigating this issue.
Posted Apr 01, 2026 - 06:12 UTC
This incident affected: SafetyCulture (Web Platform).