Unable to load training tab
Incident Report for SafetyCulture
Resolved
This incident has been resolved. Kindly refresh your page/restart the app in order to load the training tab.
Posted Apr 21, 2024 - 23:37 UTC
Investigating
We are aware of the issue with the training tab not loading. We are currently investigating the issue.
Posted Apr 21, 2024 - 22:47 UTC
This incident affected: SafetyCulture (Training).