SHEQSY experiencing service outages

Incident Report for SafetyCulture

Resolved

This incident has been resolved.
Posted Jun 01, 2025 - 01:59 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 01, 2025 - 01:41 UTC

Identified

We’re currently experiencing service interruptions with the SHEQSY application.

Our team has identified the issue and is actively working to resolve it as quickly as possible. Thank you for your patience and understanding.
Posted Jun 01, 2025 - 01:38 UTC
This incident affected: SHEQSY (SHEQSY App, SHEQSY Dashboard, SHEQSY API's, SHEQSY 24/7 Monitoring, SHEQSY Satellite Devices, SHEQSY Notifications).