Some users unable to be added to groups

Incident Report for SafetyCulture

Resolved

This incident has been resolved.
Posted Aug 21, 2024 - 11:09 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 21, 2024 - 09:43 UTC

Identified

Our team has investigated the issue and at this time we believe we have identified the cause of the issue. We are working to resolve it.
Posted Aug 21, 2024 - 03:16 UTC

Investigating

We are currently experiencing an issue that causes a small number of users not able to be added to groups. Our teams are currently investigating.
Posted Aug 21, 2024 - 02:57 UTC
This incident affected: SafetyCulture (Web Platform).