Support chat latency

Incident Report for SafetyCulture

Resolved

This incident has been resolved.
Posted Apr 14, 2026 - 13:39 UTC

Update

We’re experiencing chat routing delays due to a known issue with our third-party provider.

For assistance, you can still reach our Support Team via email or phone.
Posted Apr 14, 2026 - 12:26 UTC

Investigating

We’re experiencing chat routing delays due to a known issue with our third-party provider.
Posted Apr 14, 2026 - 12:22 UTC
This incident affected: SafetyCulture (Mobile App, Web Platform).