Weather sensors may be experiencing delays in receiving the latest weather readings
Incident Report for SafetyCulture
Resolved
The issue impacting the weather sensors should now be resolved.
Posted Nov 10, 2023 - 20:33 UTC
Monitoring
We have observed some sensors starting to come back online, and we are monitoring the progress.
Posted Nov 10, 2023 - 20:08 UTC
Update
We are continuing to investigate this issue.

We apologize for any inconvenience caused.
Posted Nov 10, 2023 - 17:28 UTC
Investigating
Customers with weather sensors may be experiencing delays in receiving the latest weather readings.

We are investigating the cause.
Posted Nov 10, 2023 - 12:30 UTC
This incident affected: SafetyCulture (formerly iAuditor) (Sensors).