Chat, email and phone support unavailable

Incident Report for SafetyCulture

Resolved

All support channels should be back to normal now.

We apologize for the inconvenience this has caused and thank you for your understanding.
Posted Apr 03, 2025 - 04:07 UTC

Monitoring

A fix has been implemented, and we are monitoring the results.
Posted Apr 03, 2025 - 03:21 UTC

Identified

The issue has been identified, and a fix is being implemented.

We appreciate your patience.
Posted Apr 03, 2025 - 03:03 UTC

Investigating

We are currently investigating an issue affecting our support channels.

Our team is working to resolve this as quickly as possible.

We apologize for any inconvenience and appreciate your understanding.
Posted Apr 03, 2025 - 02:44 UTC