Emails currently blocked to Yahoo managed email addresses

Incident Report for SafetyCulture

Resolved

This incident has been resolved. Emails are now being delivered to Yahoo managed email addresses.
Posted Jun 21, 2024 - 05:06 UTC

Monitoring

We are seeing success in the delivery of emails to Yahoo managed email addresses and are continuing to monitor the situation.
Posted Jun 21, 2024 - 01:07 UTC

Investigating

We are currently aware of email delivery issues to Yahoo managed email addresses. Our engineering teams are investigating.
Posted Jun 20, 2024 - 06:02 UTC